What do I need to use Flyp?

  1. You need an iPhone running iOS 9.0.0 or later, or an Android phone running Android 4.4 KitKat
  2. You need an active cellular voice and data plan (Flyp uses your cellular connection to get calls to you)
  3. You need somebody to call or text!
Have more questions? Submit a request

0 Comments

Please sign in to leave a comment.
Powered by Zendesk